Как установить драйвер php5-mongo нужной версии на ubuntu?

Пользователь

от josie , в категории: SQL , год назад

Как установить драйвер php5-mongo нужной версии на ubuntu?

Facebook Vk Ok Twitter LinkedIn Telegram Whatsapp

2 ответа

Пользователь

от abel , год назад

@josie 

Драйвер PHP для MongoDB версии 5 был официально прекращен, поэтому рекомендуется использовать версию 7 и выше.


Если вы хотите установить драйвер PHP для MongoDB версии 7 на Ubuntu, следуйте этим шагам:

  1. Установите необходимые зависимости:
1
2
3
sudo apt-get update
sudo apt-get install php-pear php7.4-dev
sudo apt-get install libssl-dev


  1. Установите драйвер MongoDB с помощью PECL:
1
sudo pecl install mongodb


  1. Добавьте строку extension=mongodb.so в файл php.ini. Для этого выполните следующую команду:
1
sudo sh -c 'echo "extension=mongodb.so" >> /etc/php/7.4/cli/php.ini'


  1. Перезапустите веб-сервер:
1
sudo systemctl restart apache2


Теперь вы можете использовать драйвер PHP для MongoDB версии 7 на Ubuntu. Если вы всё же хотите установить драйвер PHP для MongoDB версии 5, вы можете воспользоваться следующей командой:

1
sudo apt-get install php5-mongo


Однако имейте в виду, что драйвер PHP для MongoDB версии 5 был официально прекращен и не рекомендуется к использованию в новых проектах.

Пользователь

от ally , 2 месяца назад

@josie 

Установка драйвера php5-mongo на Ubuntu 20.04 и новее невозможна, так как этот пакет удален из репозиториев Ubuntu. Рекомендуется использовать драйвер php-mongodb для PHP версии 7 и выше. Вот инструкция по его установке:

  1. Установите необходимые зависимости:
1
2
sudo apt-get update
sudo apt-get install php-pear php7.4-dev


  1. Установите драйвер MongoDB с помощью PECL:
1
sudo pecl install mongodb


  1. Добавьте строку extension=mongodb.so в файл конфигурации PHP. Для PHP 7.4 выполните следующую команду:
1
sudo sh -c 'echo "extension=mongodb.so" >> /etc/php/7.4/cli/php.ini'


  1. Перезапустите веб-сервер:
1
sudo systemctl restart apache2


Теперь вы можете использовать драйвер PHP для MongoDB версий 7 и выше.